Оценете темата:
  • 1 гласа - средно 5
  • 1
  • 2
  • 3
  • 4
  • 5

Проблем с възпроизвеждане на видео - DRM error
#1

На Самсунг Галакси с7. С руут и xposed framework се прецака xplore tv go на А1 приложението.Самото приложение работи но като пусна видео излиза проблем с  DRM и  някакъв номер след него.Пробвах с един модул на magisk за тоя проблем,но не сработи.пробвах и ръчно да изключа  файла liboemcrypto.so по този метод ама пак не става.Забелязах че не може да се преименува файла и си остава със същото разширение.Може би и затова модула на magisk не сработи.нещо ми пречи да редактирам в system папката.а ползвах 3 експлоръра с руут достъп ,включително и root explorer. Не мога да добавя .back към файла.Иначе минавам safety net проверката,обаче идеите ми свършиха.

 Samsung Galaxy Note III SM-N9005  R✪✪T ADATA 32GB microSD HC UHS-I class 10  Android LP 5.0(QS-N9005-LP-XXUGBPB1)   
Цитирай
Зарядни и кабели usb-c
#2

(2020-10-15, 17:37:33)gibson58 написа:  На Самсунг Галакси с7. С руут и xposed framework се прецака xplore tv go на А1 приложението.Самото приложение работи но като пусна видео излиза проблем с  DRM и  някакъв номер след него.Пробвах с един модул на magisk за тоя проблем,но не сработи.пробвах и ръчно да изключа  файла liboemcrypto.so по този метод ама пак не става.Забелязах че не може да се преименува файла и си остава със същото разширение.Може би и затова модула на magisk не сработи.нещо ми пречи да редактирам в system папката.а ползвах 3 експлоръра с руут достъп ,включително и root explorer. Не мога да добавя .back към файла.Иначе минавам safety net проверката,обаче идеите ми свършиха.
Колега жив и здрав да си. При мене play diema xtra не работеше на руутнат телефон. Със Note 9 съм,какви скандали вдигах в Теленор не е истина заради това. Реших да пробвам с този модул и тръгна. Всичко бачка сега. Над година не работеше и се бях примирил вече. Благодарско.

Изпратено от СУ-57

SAMSUNG GALAXY S3 PEBBLE BLUE
NOTE 2 TITANIUM GRAY, NOTE 4 SM-N910C
[-] 1 потребител изказва благодарност на bavarec6 за това мнение:
  • Be6i4
Цитирай
#3

Радвам се ,че поне на теб ти е свършил работа.и аз ги скастрих а1. И накрая казаха че нещо телефона не ми бил наред а в началото си работеше всичко и след няколко дни спря.

 Samsung Galaxy Note III SM-N9005  R✪✪T ADATA 32GB microSD HC UHS-I class 10  Android LP 5.0(QS-N9005-LP-XXUGBPB1)   
Цитирай
#4

здравейте, xplore tv go ми вади DRM грешка на тв бокс.
Проверих с root checker и пише, че боксът не е root-нат. x88 pro 4GB ram с android 10. Поне така пише.

Има ли някакъв шанс да подкарам xplore tv go? Инсталирах app-а през play store, когато пусна предаване, вади греката и до там.
Цитирай
#5

И аз съм със същия проблем вече една година и решение не намирам никъде. Мултимедията в колата ми е с андроид, които уж не е руутнат (поне програмите които чекират за руут, така изписват) и на мен ми дава DRM грешка. Същевременно на тв бокса ми Zidoo x6 pro , който е руутнат, също ми изкарваше DRM грешка, но след като скрих руут с magisk hide, телевизията тръгна.
Цитирай
#6

значи трябва да си руутнем тв боксовете и да скрием руута за това приложение? Smile
И аз ще слагам тв бокса в колата и затова ми трябва. Не разбирам защо е тази защита и на А1 какво им пречи дали гледам на телефона ми в колата или на тв бокс...
Цитирай
#7

(2020-10-15, 20:57:52)gibson58 написа:  Радвам се ,че поне на теб ти е свършил работа.и аз ги скастрих а1. И накрая казаха че нещо телефона не ми бил наред а в началото си работеше всичко и след няколко дни спря.

Братле трябва през протекцията да скриеш magisk за приложението а1

(2020-10-15, 17:37:33)gibson58 написа:  На Самсунг Галакси с7. С руут и xposed framework се прецака xplore tv go на А1 приложението.Самото приложение работи но като пусна видео излиза проблем с  DRM и  някакъв номер след него.Пробвах с един модул на magisk за тоя проблем,но не сработи.пробвах и ръчно да изключа  файла liboemcrypto.so по този метод ама пак не става.Забелязах че не може да се преименува файла и си остава със същото разширение.Може би и затова модула на magisk не сработи.нещо ми пречи да редактирам в system папката.а ползвах 3 експлоръра с руут достъп ,включително и root explorer. Не мога да добавя .back към файла.Иначе минавам safety net проверката,обаче идеите ми свършиха.

Ако си с Magisk 23 на колелцето за настройките даваш magisk hide permission 
След тва се връщаш и на щита долу натискаш после намираш а1 приложението и скривал всичко за него и си върви даже нета да ти е бавен като охлюв ???
Цитирай
#8

Явно a1 xplore tv проверява за руут по абсолютно различен начин ( по скоро false positive проверява нещо грешно... imo ), защото при safetynet pass , google pay работещ без проблем , банкови апове работещи без проблем с magisk hide , само a1 xplore tv продължава да гърми с drm error - някой да е дизасемблирал apk-то да даде идея какво проверява толкова , единствено успях да го излъжа с universal safetynetfix 2.1.1 + riru , в което няма никаква логика и преди него safetynet evaluation-a е свален на basic и си минава без проблем , cts profile-а не е манипулиран , оригиналния е, същото и с fingerprint-a, странното е че работеше преди само с magisk hide на апа , не го бях пускал доста време ,ъпдейтвал се е сигурно и е спрял да работи , не е голям проблем но ме човърка , съмнява ме някой друг да не се е сблъскал с проблема , тествано на 3 устройства , magisk hide само не сработва вече , може би zygisk-a ще го оправи , но до там има доста време , та някой да има някаква друга идея ?
Цитирай
#9

Ползвам Xiaomi Mi9 Pro 5G, root-нат и с инсталиран Magisk 23.0.
От известно време Xplore TV (v. 17) не тръгва като дава DMR грешка. Дори и след като скрия приложението не тръгваше. Днес свалих по-стара версия ( 10.0.10) и след като рестартирах "скриването" на приложението в Magisk, вече ТВ работи...

Дано да помогне това ....
Цитирай
#10

Пробвано - работи и то на Magisk 24.1 (няма magisk hide)
Magisk > Restart to Recovery
Twrp > mount > слоци отметка 'vendor' > back > Advanced > file manager.
Намерете следните файлове и ги изтрийте:
Код:
vendor/lib64/liboemcrypto.so
vendor/lib/liboemcrypto.so
Аз лично изтрих Magisk модулите за премахване на RDM и за триене на liboemcrypto.so, рестарт > 
Изчистих Xplore TV данните на аппа и след login - работи (не знам до кога, че и преди го бях подкарвал)

Забрваих, че съм пуснал Zygisk и от листата отдолу съм сложил отметки на аппа Xplore TV
[-] 1 потребител изказва благодарност на kamikadzzze за това мнение:
  • Be6i4
Цитирай




Потребители разглеждащи темата: 1 гост(и)