Оценете темата:
  • 0 гласа - средно 0
  • 1
  • 2
  • 3
  • 4
  • 5
Важни промени в Google Play
#1

мнение 1 от yo_asakura

https://android-developers.googleblog.co...mance.html

 Според статията по-горе от Август другата година, Google Play ще приема нови приложения само, ако са компилирани с API 26 или по висока версия на Андроид. А от Ноември не само новите приложения, но и обновления на стари ще се приемат само с API 26 или по висока версия. След това 2019 нуждната API версия ще се покачи и така всяка година. Това ще принуди всички девелъпъри като пускат нови приложения или обновяват стари да ги компилират с най-новите библиотеки и евентуално да интегрират най-новите функции. Но най вече ще се спазват правилата в най-новите андроид версии като нуждата от runtime permissions.
 Смятам, че това е доста важна информация и променя дръстично нещата в Google Play. Естествено, ако някое приложение не се обновява никога, то ще продължи да си работи и съществува, но поне тези които се поддържат, ще трябва да са в час с обновленията. Аз лично мисля, че това е добра промяна, защото приложения като Facebook, Messenger, Viber и подобни, искат не искат, ще преминат към Adaptive Icons (Налични в Орео), а няма да си кретат с едни и същи икони от години и да се губи идеята от оеднаквяване на всички икони в Андроид. Ествествено ще има нужда от по подробно запознаване с новостите и повечко работа, но мисля, че поне хората които си поддържат приложенията ще се отличат спрямо приложения, които си гният на едно и също място и си карат с едно и също API от години - и както казах нямат и намерение за преминаване към Adaptive Icons или като някои приложения, все още не приели новия permission модел, който го има още от API 23, а най-новото в момента е API 27. Вие какво мислите за тази промяна?
Цитирай
#2

мнение 2 от Miro2210

Аз ли така го разбирам или греша,ако дадено приложение  подържащо API 19+ след тези промени то ще трябва да бъде компилирано с target API 26 и то няма да ппдържа старите андройди?Ако е така малко глупаво ми изглежда...
Цитирай
#3

мнение 3 от yo_asakura

Не! Минималната версия може да е каквато поискаш (с новия гредъл 15+). Просто версията с която компилираш трябва да е нова. Демек, няма как приложението ти да не се подчини на Adaptive Icons, Runtime Permissions и други подобни новости.
Цитирай




Потребители разглеждащи темата: 1 гост(и)

НАЧАЛО